Articles taggés installation

Comment modifier le passphrase de SharePoint 2010

PassPhrase de SharePoint 2010 perdu: Comment le récupérer ?

0

Vous avez installé une ferme SharePoint 2010 et vous ne vous rappelez pas du PassPhrase ?

Alors j’ai pour vous une bonne et une mauvaise nouvelle:

La mauvaise: Vous ne pouvez pas récupérer le passphrase que vous avez saisi lors de l’installation de la ferme !

La bonne: vous pouvez le changer quand vous le voulez, pour y parvenir:

  • Commencez par ouvrir le « SharePoint 2010 Management Shell »:
  • Exécutez la commande suivante:
    $passphrase = ConvertTo-SecureString -asPlainText –Force
    
  • Saisissez le nouveau PassPhrase, et appuyez sur « Entrée »

    NB: Le passphrase devrait comporter au minimum 8 caractères, une majuscule, et un chiffre.

  • Exécutez la commande suivante:
    Set-SPPassPhrase -PassPhrase $passphrase –Confirm
    
  • Retapez le passphrase que vous avez saisi préalablement
  • Tapez « Y », puis appuyez sur « Entrée »
  • Le résultat devrait ressembler à:
    Comment modifier le passphrase de SharePoint 2010

Le changement apporté prend effet instantanément, et vous n’avez pas besoin d’exécuter cette procédure sur tous les serveurs de la ferme.

N’hésitez pas à faire des remarques et laisser des commentaires ;-)

Impossible d’activer la version Enterprise de SharePoint 2010 après une installation avec SPModule

0

Si vous avez installé une ferme SharePoint 2010 via le module Powershell « SPModule », et que vous avez utilisé le fichier de la configuration de l’installation « Config.xml », contenant le clé de la version Enterprise de SharePoint 2010. Vous avez donc, surement remarqué que les Features Enterprise ne sont pas activées (Excel services, …).

Ce problème est dû à une erreur de développement du module, qui ne prend en compte, que la clé renseignée dans la paramètres de la commande, avec le paramètre « -PIDKEY », sinon il attribue une clé « trial », qui ne permet pas d’activer les Features Enterprise.

Pour palier à cette erreur, il y a deux méthodes:

  • Allez sur la Central d’administration ==> Upgrade and Migration ==> Enable Enterprise Features:
    • Cochez « Enterprise (Requires Enterprise client license) »
    • Saisissez la clé Enterprise
    • Cliquez sur OK
      N.B.: Cette Méthode ne fonctionne pas pour toutes les clés Enterprise! Si c’est le cas, il faudra passer par une réinstallation de la ferme.
  • Modifiez le script « Install-SharePoint.ps1″ de SPModule, de manière à prendre en considération la clé présente dans le fichier de configuration, et réinstaller la ferme.

    Pour cela il faudra ajouter la ligne suivante, à la ligne ~370 :

    $PIDKey = $CurrentConfigXml.Configuration.SelectSingleNode("PIDKEY").Value
    

    Juste avant:

    
            if ($PIDKey)
            {
                # Ensure we honor the PIDKey
                $CurrentConfigXml.Configuration.PIDKEY.Value = $PIDKey
            }
    
  • Et remplacez les lignes ~413 et 414:
    $ConfigXmlPath = Join-Path $env:temp $ConfigXmlName
    $CurrentConfigXml.Save($ConfigXmlPath)
    

    Par:

    $TempConfigXmlPath = Join-Path $env:temp $ConfigXmlName
    $CurrentConfigXml.Save($TempConfigXmlPath)
    
Haut de page